...making Linux just a little more fun!

<-- prev | next -->

More Two Cent Tips!

See also: The Answer Gang's Knowledge Base and the LG Search Engine

no-floppy system configuration

Thu, 8 Jan 2004 11:47:45 -0500
Ben Okopnik (The LG Answer Gang)

Many new laptops come without a floppy drive; the one that I just bought, an Acer Aspire 2003LMi, does not have one - it's available as an extra option, but I don't see myself needing it. However, part of my standard method for converting Win-machines to dual-boot involves using FIPS, which I use to "shrink" the Wind0ws partition to a minimal size - and FIPS normally runs from a floppy. What to do?

Here's an interesting fact that many people may not be aware of: the bootable part of a CD consists of nothing more than a bootable floppy image. So, I simply took a DOS boot floppy containing FIPS, and made a byte-by-byte copy:

# Create a directory to hold the CD data (none at the moment) plus "boot"
ben@Fenrir:~$ mkdir -p /tmp/cdrom/boot
# Create byte-by-byte copy in "boot.img"
ben@Fenrir:~$ dd if=/dev/fd0 of=/tmp/cdrom/boot/boot.img

I then created an ISO image containing that disk copy. If I wanted any other data on that CD (I'll probably make another one with a bunch of DOS utilities on it later; I've been using bootable DOS "tool" floppies for over 20 years to repair broken Wind0ws systems), I'd copy that data into "/tmp/cdrom", and it would become part of that image.

ben@Fenrir:~$ cd /tmp/cdrom
ben@Fenrir:/tmp/cdrom$ mkisofs -r -b boot/boot.img -c boot/boot.catalog -o bootcd.iso .

All that was left was to burn the newly-created image to a CD:

ben@Fenrir:/tmp/cdrom$ sudo cdrecord -v -eject speed=8 dev=0,0,0 bootcd.iso

The only downside to this is not being able to save the boot sector to the floppy before repartitioning... but in the worst case, it's a new system without any of my data on it, and it's not a concern. Besides, I have Linux, and boot sector recovery is rather trivial. :)

Nice value in XFree86 startup

Sat, 24 Jan 2004 21:56:43 +0000
Thomas Adam (The LG Weekend Mechanic)
Question by Jacobo ;-) (jacobo221 from hotmail.com)

Hi, first of all, sorry for my english, I try my best, but I use to fail in spelling and grammar ;-) Well, I'm writting to you because I have a problem at Xfree86's startup. I'm useing kernel 2.4, so I have, in Xwrapper.config, nice value set to -10 ("nice_value=-10"), but when entering "startx", just before entering Xfree86, a message is shown: "warning: process set to nice value -11 instead of -10 as requested". If I then change nice value to -11, then the startx script changes nice value to -12. If I change it to -12, it changes it to -13, and so on for any number between [-20, 19]. I've searched for many days (weeks, in fact) on the web and asked at #debian, but no answers. I hope you can lend me a hand. Btw, XFree86 runs perfectly ok, it's just that I hate having error messages. Thanx a lot for your help!

[Thomas] By my knowledge of how X starts up it is not startx which is changing this. Just out of curiosity, run (as root):
dpkg-reconfigure xserver-common
to see if that fixes anything. I have grepped through the startup files that I use (I am running debian unstable) and there is nothing besides the value in /etc/X11/Xwrapper.config which sets or changes the nice value of X.
As a long shot (and possibly a complete aside) you don't have the "and" package installed, do you?

CPU Support on Linux

Sun, 22 Jun 2003 14:10:02 +0100 (BST)
Ashwin N (The LG Answer Gang)
Question by Shishir_Bagchi (Shishir_Bagchi from lko.tcs.co.in)

Upto how many CPUs does Linux Support in --

a) CISC Technology

b) RISC Technology

[ashwin] The numbers for the individual architectures for the current kernels can be got here - http://www.tldp.org/HOWTO/SMP-HOWTO.html
Expect much much better support with the 2.6 series.

mac 5200

Wed, 31 Dec 2003 19:53:51 -0500
Neil Youngman (The LG Answer Gang)
Question by sheldon k feldman (cru1se from comcast.net)

Can I load linux onto this machine? Where do I get the software? thanks

[Neil] MkLinux supports the 5200 see http://linuxtoday.com/developer/2000080401404OSHWKN
Other Mac Linuxes include Yellow dog Linux


Fri, 6 Jun 2003 22:17:25 EDT
Weswwallace (Weswwallace from aol.com)
Answered By Jason Creighton

How do I get an E-maikl to above subject? They interrupt my messages.

[Jason] What you seem to be asking is "why am I getting messages from Mailer-Daemon"? A message from "Mailer-Daemon" is probably the MTA (Mail transport agent: The software that delivers mail.) sending a message that says, in effect, "excuse me, but you seem to be confused. There is no such mailbox here."

claim no such addresses exist, etc.,

[Jason] The automated message you're recieving means just what it says: No such address exists. For example, if you try to send email to bob@example.com, and there is no user bob at example.com, you're probably going to get a bounce message that says no such address exists.

yet they cannot be questioned or challenged ever when they are wrong. Help.

[Jason] The reason "they" cannot be questioned is because you're getting an automated message: It was not send by a human.
Nobody would know better whether an address exists than the system you're sending mail to, so I would say that the system you're sending mail to is right and you are wrong.

what is "no"? (missing prog for binutils compile)

Thu, 29 May 2003 15:53:14 -0700
Faber fedor, Jim Dennis, Alan Mudra (The LG Answer Gang)
Question by Karl-Heinz Herrmann

Now -- it's an unbearable situation that my Linux doesn't know "no".... But I've no idea what it is and you can imagine that a google for "no" even with linux and some other keywords around are not very helpful.

Any ideas?

[Faber] Maybe it's called "nein" on your computer? <grvf>
I can't find a "no" on my Red Hat 8 box either.
[JimD] I think /usr/bin/no was (would be) a counterpart to the old /usr/bin/yes command:
	[ "$#" -gt 1] && OUTPUT="$*"
	while : ; do
		echo "$OUTPUT"
... so "no" could just be an alias or script that calls /usr/bin/yes with the "no" argument:
		 /usr/bin/yes no
I realize this sounds silly and stupid, and April 1st is long past for this year. But I'm not kidding. That Makefile (or whatever) seems to actually want to pipe an endless stream of "n" or "no" lines into some other process. (/usr/bin/yes was traditionally used in a pipeline with fsck to automate the process of repairing a filesystem that need lots of work -- then they just added the -y option to the GNU/Linux versions of fsck.

I put the question up with bugreports for binutils and got:

> /bin/sh: no: command not found
This is a result of binutils being stuck on using old buggy autoconf. Install a new version of GNU gettext, or configure with --disable-nls.
-- Alan Modra IBM OzLabs - Linux Technology Centre

Got a new gettext which includes some "no"'s

khh > find ./ -name "no*"

unfortunately with a new gettext (gettext-0.12.1.tar.gz) and nls enabled I get a linker error for some gettext symbol. The solution without nls works for getting binutils compiled. I try that on the 2.5.70 kernel sometime soon.

Does anybody know of a backport to 2.4.X of the preempt patch and or the I/O scheme patches mentioned on kerneltrap right now? I'm not yet sure what else will break if I switch to 2.5.X. At least NVdriver, lt_serial+lt_modem and vmware kernel modules would be nice to have.

What is Linux Torvalds wife famous for

Thu, 19 Jun 2003 15:00:53 +0100 (BST)
Ashwin N, Thomas Adam (The LG Answer Gang)
Question by Pam Drake (pdrake from northern.wvnet.edu)
[Thomas] Well, she's famous for being married to Linus Torvalds.
[Ashwin] She is also famous for being Finland's champion in kung-fu or some similar martial art ;-)
Linus was interviewed in Issue 67 of Linux Journal, by Marjorie Richardson at the Linux World Expo of that year. Tove was 6 years running, the Finnish champion for karate, specializing in precise Kata (the forms), then moved on to other interests. -- Heather

pppd problem

Thu, 26 Jun 2003 01:30:57 +0530
Joydeep Bakshi (joy12 from vsnl.net)
Answered By Thomas Adam

Hi all,

I use kppp under linux to dial-up my isp. but there is a strange problem happens with me. when I dial-up from windows98 it connects with the isp at the very first attempt. but under Linux (debian woody) kppp takes at-least 3/4 attempts to connect the isp, and during the failure it shows *pppd can't be started * . I have also started pppd from root manually at the time of hooking, but the result is same. could some one please suggest me how to fix the problem ?

thanks in advanced.

[Thomas] You need to ensure that you have a ppp-chat script enabled which is used by pppd to comminicate with the modem to send certain signals, etc.
wvdial will help for this

PPP & ETH won't work concurrently

Fri, 5 Dec 2003 09:48:52 -0800 (PST)
Joe Slobotnik (cj from rt.nl)
Answered By Thomas Adam, Karl-Heinz Herrmann


I'm running red hat 9 with an ethernet card to a LAN and a modem for dial up. I'm using kppp for the dial up. When the eth0 int is active, kppp will establish a connection but DNS fails. The DNS listed for both interfaces is the dialup one, but I can't resolve names unless the eth0 is shutdown. How can I , an ordinary joe get these things to work at the same time ?


[Thomas] There is either a really easy or hard explanation. I think I am right in saying that you need to have a correct entry in your routing table to use the two concurrently, since the routing will not know.
As far as DNS goes, do you have a valid entry in /etc/resolv.conf and also an entry in /etc/nsswitch.conf:
hosts: files dns
like that? If not, add the "dns" after the word "files".
[K.-H.] Well kppp (or pppd which kppp calls) refuses to setup a default route if one already exists. The magic scrying ball (glass?) would suggest with eth0 up you've a default route set. On dailup via kppp you won't get a default route to your ppp0 interface and therefore DNS lookups to the world outside never reach there.
This is how it should look lie with both eth0 and ppp0 (kppp) up (I cut out three columns which are unimportant):
# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags  Iface UH     ppp0 UH     dummy0   U      eth0   U      vmnet1         UG     ppp0
I've two private networks, real ethernet as and vmware virtual host as The "0" at the end suggests and a genmask of proves that these are networks, i.e. not a single host but all hosts 10.10.10.x with 1<x<255 (zero is broadcast address to all). If you look at the flags "H" means this is only one single host, "G" means this is a gateway.
The last line is the default routing, i.e. if no other routing rule applies all remaining traffic this way. The way is interface ppp0 and the target the gateway IP, our remote host on the other end of the modem line (see first line).
Now I'm pretty sure that in your case there is a line like:      [some IP]         UG      eth0
If this is the case kppp will not touch it and if you would have looked carefully in your /var/log/messages (or kppp's log) you would have found an error telling you this.
If I guessed right run (as root):
route del default
then start kppp's dialin
After that figure out why RedHat sets a default route (I'm with the lizard and without hats).
If I did not guess right you oviously didn't give enough information....

Red Hat Linux Install issues

Sun, 29 Jun 2003 15:34:59 -0400
Srinivas Velury (s_velury from hotmail.com)
Answered By Mike Martin

Hi Answer Guy,

I am having a peculiar problem with the Red Hat 9 installation. I am trying to install it on a IBM thinkpad 1721 laptop with a formatted hard drive. The laptop has a combo floppy/CD ROM drive. The laptop seems to be seeing the CD ROM dirve but it is not able to read anything off it. The laptop has a PCMCIA network adapter card which I used to connect to my home networking. The other laptop on the home networking has Win 2000 running on it. Here are the following waya I tried to install Linux -

1. I created a Linux boot disk using the pcmcia.img and booted the IBM laptop and selected NFS install. On the other laptop I copied all the Red Hat folders from the 3 installation CDs. I selected "Automatic DNS configuration" to configure the DNS names for the IBM machine. For the NFS server name I typed in the name (which did not have a domain name since I log into a workgroup and not a domain) and typed in the actual directory of the Redhat parent folder (d:\redhat9). But I get an error that the drive could not be mounted.

Then I grabbed a Freeware called NFSClientServer and installed it on the Win 200 laptop. Here I exported the RedHat directory (d:\RedHat9\RedHat). Then I followed the above steps on the IBM machine for NFS installation. Even though my requests form the IBM machine seemed to log in the Server log on the Win 2000 machine, I still could not mount the directory. What am I missing?

2. Failing the above attempt, I attached a SCSI CD ROM to my IBM machine. Then I made a boot disk using the bootdisk.img. After booting the IBM, I selected "local CDROM" for the source, but I kept getting the message "No software found in CDROM". Obvously, Linux was not seeing my SCSI CDROM, but since it detected my internal (failed) CDROM, and could not read off of it, it was giving me the message. How do I make it look at my SCSI CDROM?

I even tried making a boot disk using the "drvblock.img" file, but for some reason when I use the disk, I get the message " No operation system found". When I look at the disk contents the, it seems like the format information on the disk is lost and Windows explorer asks me if I "want to format the disk"? I even tried the same using Linux 7.3 (Red Hat), same error.

Please help.

A Wexed Linux Installer.

[Mike] OK - your best bet would be a HD install. If you have copied the folders over you have enough HD space.
In w2k make a directory to hold the iso images In turn copy the cds to this directory (not the contents - I think Nero should be able to do this) You should then have three files in this directory, all ending in .iso
Now boot using your boot.img disk. When you get get prompted for installation type, choose HD then select the right partition where there are held (probably /dev/hda1 on your system if you choose the first partition) then select the directory you have placed the .iso files in.
Then you should be good to go.

pam and ssh

Wed, 25 Jun 2003 10:08:28 -0500
Lou Lohman (LLohman from WeberMarking.com)
Answered By Thomas Adam, Michael Gargiullo

Dear Answer Gang,

Try as I might, I am unable to figure out just what to do to allow a trusted user on a trusted host to use 'scp' to copy files from one system to another WITHOUT a password prompt. We WANT to do this in order to use 'scp' in scripts initiated by CRON. We NEED to do this because 'rcp' gives us 'file too large' responses. I have tried modifying /etc/pam.d/sshd (at least to the limits of my understanding). I can make scp NOT work at all, or require the password, but I cannot make it work without the password. Changing the /etc/ssh/sshd_config file doesn't make any difference, that I can see, even though that file now says 'go ahead and use the rhosts files'.

Can someone help me? Anyone? I would offer a carrot, like "I'll subscribe to LJ", but I already do. I would offer virtual hugs and kisses, but the respondent might be male, in which case an old homophobe like me is going to have a problem. How about "undying gratitude"? Yeah, that's the ticket ... it's easy, it's cheap, I could even teach my kids to sing appropriate praises .. yeah, that's it .... Where's Jon Lovitz when you really need him?

Lou Lohman

Don't just BELIEVE!! Consume information like a starving person, and then sort it out for yourself.
And we know he reads ask-the-gang.html, he gave us explicit permission to publish the whole thread just like we ask for :) Now if we could get people to remember to turn off HTML in their email... -- Heather
[Thomas] You need to run "scp" with the "-B" flag, ie.
scp -B files thomas@thomas
Batchmode doesn't require password authentication. You can also add this in /etc/ssh_config as...
that way, you don't have to pass the -B switch each time.
[Mike] You can also exchange keys from one user/machine to the other. If you want to copy from machine A to machine B. On machine A, as the user that needs to copy, run ssh-keygen -t dsa. This will generate the key pair. Then he'll need to copy the contents of ~/.ssh/id_dsa.pub from machine A into ~/.ssh/authorized_keys on machine B. Then copying from machine A to machine B won't require a password for this user. Do the reverse to copy from B to A.

Pctel modem ................NO CARRIER..........?????

Thu, 26 Jun 2003 08:22:13 +0530
Vivek Ravindranath (vivek_ravindranath from softhome.net)
Answered By Karl-Heinz Herrmann

Hi Answer Gang,

I have some problems trying to connect with my HSP Pctel Micromodem 56.I have RedHat 9 installed and I use kppp for conneting to the net.When I try to connect the handshake goes on well and all of a sudden I get this "No Carrier" message.Can you tell what causes this error and what is the solution.............please sugget an alternative driver if available.At present I am using the Pctel drivers available at www.linmodems.org version 0.9.6 . Can any special AT command string help?????? If yes please suggest a solution.Or using any other dialer will help????

Thanks in advance.


[K.-H.] no carrier means the modem is unable to detect the carrier frequency onto which data would be encoded. As this is a fatal problem it hangs up and tells you "no carrier".
Why is the carrier gone? difficult to tell from here. What do your logfiles say? kppp has a log button, use it!
At exactly what point of connection negotiation does the error occur? Do you get the "connect" in the log window? Then the dialing is finished and control passed to pppd -- which logs it's messages in /var/log/messages or some such place. Go look for it. You can pass additional option to pppd in kppp: add "debug". Make sure to press the add button in the kppp window so the new option is actually used (should show up in the lower larger window).
My guess: serial connection gets established, pppd get's into some trouble negotiating the ppp parameters (user/passwd? pap <-> chap <-> terminal authentification, compression,.... ) and the other side terminates on you. Your modem detects the lost carrier and tells you.

Which VT? Custom prompts.

Mon, 23 Jun 2003 13:59:58 +0100 (BST)
Toby Poynder (toby from whatcouldpossibly.com)

Here's a suggestion for your 2 cent tips section - I hope you like it.

When working with Linux servers I don't run X, preferring to make use of the virtual terminals via Alt-F1, Alt-F2, Alt-F3 etc. The problem is knowing which screen I am looking at, so I have devised a custom prompt by including the following two lines in my .profile:

TTY=`basename \`tty\" export PS1="[$TTY] \w$ "

Cool :)

The first line sets the environment variable TTY to the number of the current virtual terminal, the second sets my prompt to show that number and the current working directory as in this example:

[2] /etc/xinetd.d$

That's it!

Toby Poynder London, UK

I must admit that I often find just typing in "tty" is more efficient than having it set in one's $PS1 prompt. :) -- Thomas

workaround for black lines on Radeon mobility 7500

Wed, 14 Jan 2004 22:06:10 +0000
Adrian Bridgett (adrian from smop.co.uk)

To workaround black lines in XFree86 with Radeon mobility 7500 (thinkpad R40 here), add:

Option ""XaaNoSolidTwoPointLine""

To the drivers section of /etc/X11/XF86Config(-4)

Adrian (aka Wyvern on #hants)

Cool toy of the week: XaoS

Mon, 16 Jun 2003 20:43:40 -0600
Jason Creighton, Faber Fedor, Ben Okopnik (The LG Answer Gang)
What is it, you ask?
Real-time fractal zoomer.
If that isn't enough to get you to run out and download it, you're probably not the kind of person who would enjoy it. :-)
[Ben] And don't forget to take a look at the sample fractals that come with the "xaos" package, located (under Debian) in /usr/share/XaoS/examples. (I've got all of these converted to JPGs and use them as randomly-selected desktop backgrounds.) Beautiful.
[Faber] Yes, a very nice toy, but I still miss Fractint for DOS. The X/Windows version had all the features, but just doesn't cut it somehow. A Mandelbrot set not being full screen looses something, not to mention they're slower than the DOS version.
I also had an internal IBM program[1] that would map out different phase space maps stereographically, looking like some of the maps in the Discrete screen saver in xscreensaver.. Man that was a fun toy; I wish I could find the source code (it was floating around here on disk years ago); I'd try to port that to Linux.
[1] For those of you that don't know it, IBM has a a mini Internet in place with their own version of "free software", to wit programs written by Beamers and distributed to other Beamers for fun and collective profit. And since some of those people had multiple PhDs and worked on esoteric stuff, some interesting programs cropped up. It's the only thing I miss from my IBM days.

This page edited and maintained by the Editors of Linux Gazette
HTML script maintained by Heather Stern of Starshine Technical Services, http://www.starshine.org/


Copyright © 2004, . Released under the Open Publication license unless otherwise noted in the body of the article. Linux Gazette is not produced, sponsored, or endorsed by its prior host, SSC, Inc.

Published in Issue 99 of Linux Gazette, February 2004